The link to access the Subscription Manager redirects to the login page
Incident Report for Ordergroove
Resolved
Shopify has implemented a fix for this. We are going to close this incident since we confirmed that the subscription manager is back to normal for everyone now. Feel free to check Shopify's status page or reach out to Shopify for more details on this issue.
https://www.shopifystatus.com/

Thank you for your patience!
Posted Jan 19, 2024 - 14:51 EST
Identified
It seems that this issue has been introduced yesterday by a change on the Shopify side on the Proxy URL page. Shopify's support is aware of this issue and Shopify's team is working on it.
Posted Jan 19, 2024 - 11:35 EST
Investigating
For Shopify merchants, the link redirects to the login page instead of the Subscription Manager. We are currently investigating and reaching out to Shopify support for more information.
Posted Jan 19, 2024 - 10:52 EST
This incident affected: Shopify (Ordergroove App - Subscription Manager (previously SMI)).