Inaccurate Revenue Data
Incident Report for Ordergroove
Resolved
This issue has been resolved. We are working with our Business Intelligence tool to prevent this issue from happening again.
Sorry for the inconvenience
Posted May 02, 2023 - 11:30 EDT
Investigating
The Revenue Data is incomplete and inaccurate. We are investigating this issue.
Posted May 02, 2023 - 10:30 EDT
This incident affected: Ordergroove Platform (e-commerce platform agnostic) (Analytics & Reporting).