The Analytics page is showing incorrect data
Incident Report for Ordergroove
Resolved
This incident has been resolved and all the historical data is now correct.
We will work with our business intelligence software to prevent this from happening again.

Thank you for your patience and sorry for the inconvenience
Posted Apr 19, 2023 - 21:37 EDT
Monitoring
The data is now correct again, although we are still monitoring this very closely
Posted Apr 19, 2023 - 18:15 EDT
Investigating
We are having an issue with our Business Intelligence tool that is rendering incorrect data (mainly in the Revenue tab).
Data Exports are not impacted by this issue.
Posted Apr 19, 2023 - 13:25 EDT
This incident affected: Ordergroove Platform (e-commerce platform agnostic) (Analytics & Reporting).