Analytics page not loading on Ordergroove Dashboard

Incident Report for Ordergroove

Resolved

A compatibility issue with our analytics provider was causing dashboards to fail to load. We've applied a fix and verified Analytics is working as expected. Thank you for your patience.
Posted Jun 22, 2026 - 17:30 EDT

Update

The incident is still under investigation.
Posted Jun 22, 2026 - 15:13 EDT

Investigating

We're investigating reports of the RC3 analytics page experiencing issues while loading metrics. The issue doesn't affect metrics collection. Reporting has not been affected.
Posted Jun 22, 2026 - 14:08 EDT
This incident affected: Ordergroove Platform (e-commerce platform agnostic) (Analytics & Reporting).